Technical FAQs

Ask a Question

What is the solution for "ERROR IN LANGUAGES" message in LTMCU display, after replacing OLD LTMR08EFM relay with new LTMR08EFM relay?


The LTMCU "ERROR IN LANGUAGES" accrue, when the firmware version of the LTMR is FW2.5 or later but the LTMCU still has language files for FW2.4 or earlier loaded.

Both languages versions 1.100 and 1.200 are compatible with LTMCU FW 1.2. However with LTMR FW2.5 or later, language version 1.200 is necessary. Also the new relay with Firmware 2.7 the language version of LTMCU has to be 1.300 or higher.
In case your LTMCU is not loaded with the right languages version, you will have a language error message at product power up. Once cleared, this message doesn’t stop the correct operation of LTMCU However; one parameter added in FW 2.5, FW2.7 won’t be available.

The LanDown tool and LTMCU Language version 1.300  is attached herewith for your reference. You can just update the language version to avoid language error.

We believe above information provided will clarify your query Please feel free to contact us for any of further assistance.
Was this helpful?
What can we do to improve the information ?